Get in touch
Back
Maintenance

Upgrading database

Completed 22 Oct at 09:40pm CEST.

QuickMail Application
Completed

Maintenance completed

Posted 22 Oct at 09:40pm CEST.
Started

We are upgrading to a bigger database to help us scale.

Posted 22 Oct at 09:28pm CEST.