Get in touch
Back
Resolved

System delay

Started 21 Jun at 05:19pm CEST.

QuickMail Application
Created

The delay has been solved. We will continue to monitor the system in the next hours.

Posted 21 Jun at 05:19pm CEST.