Get in touch
Back
Resolved

Service outage

Started 10 Jun at 09:22pm CEST.

QuickMail Application
Created

Our hosting provider has a massive outage. https://status.heroku.com
Things are very slow or not processing as they should.
You can still browse your projects but no jobs are running properly

Posted 10 Jun at 09:22pm CEST.